Error on Volume

Last comment 12/03/2020 10:00 by Fabio
· Mark as unread
Fabio Fronda 2 months ago created
Hi, I got a strange error running BMECAT Validator on all UDX.EDXF.VOLUME Tags.
The report says Error 1824: Element 'UDX.EDXF.VOLUME': '6.96E-6' is not a valid value of the atomic type
'dtNUMBER'. Occurrences: 3. First in line: 2.
Here is what I've sent:             0.000696

The strange thing is that I've also written 
  0.01
            0.012
            0.2
            0.29
and those fields caused no errors.
Does someone get these errors too?

Thanks a lot for your help or suggestions.

Fabio
Gabi Jongste 2 months ago created
I'm having the same problem this morning
Erik Sanberg 2 months ago created
I believe the values in this field work better if you limit it to 4 decimal digits max.
Just use a rounding formula ....
Marc Habets 2 months ago created
Dear Fabio, when you mean the BMEcat validator, what tool are you referring too? I tested UDX.EDXF.VOLUME =  0.000696 in our official ETIM BMEcat certification tool at https://xmlvalidation.etim-international.com/ and it does NOT give an error on that. The ETIM BMEcat guidelines give no restrictions to the number of decimals for datatype dtNUMBER.
 
Perhaps you used https://etim-validator.com/ ? Then maybe @grzegorznowak​ can help.
Fabio Fronda 2 months ago created
Hi Marc, yes I've used etim-validator.com. I will contact  @grzegorznowak
Grzegorz Nowak 2 months ago created
Hi.
I am responsible for etim-validator.com
I have just checked and the volume like 0.000696 is accepted without any error.
Fabio, please send me your BMEcat file causing the problem to my e-mail (gnowak@mediab.pl and tell me what settings do you use for validation (automatic/guideline version/country) - I will try to reproduce the behaviour to be able to analyze the issue.
BR
Grzegorz
Grzegorz Nowak 2 months ago created
Sorry, the spelling mistake in my e-mail. It should be: gnowak@medialab.pl
Grzegorz Nowak 2 months ago created
Hi, It's me again. I have just managed to reproduce the issue. It seems to me that you used the scientific notation: 6.96E-6 instead of decimal notation 0.000696.
The scientific notation is not recomended in BMEcat files and the offcial certification tool doesn't support it either. Below the message from the certification tool for the value given in the scientific notation.
Grzegorz

Fabio Fronda 2 months ago created
Yes, you're right!
I've just tried again formatting numbers without scientific notation and it worked like a charm.

Thanks a lot to all of you for your help!

Fabio
Join the conversation
You have to be a registered user to join the conversation.
Topic started 06 March 2020 at 16:53
Reader count 9
Comment count 9